Kali Linux: Hacking Networks Part 1


33 thoughts on “Kali Linux: Hacking Networks Part 1

  1. Menu:

    Overview: 0:01
    Yersinia Overview: 0:58
    Install Yersinia: 3:08
    Yersinia options: 4:07
    Run Yersinia: 4:40
    Use Putty to view Switch configuration: 5:38
    Bridge Kali Linux to the physical Ethernet network: 10:28
    CDP flooding: 11:40
    Spanning Tree (STP) hacking: 13:49

    ======================
    Previous Video:
    ======================
    Kali Linux installation video: https://youtu.be/AnwgxRtWXLI

    ======================
    CCNA content:
    ======================
    Free CCNA content: https://www.youtube.com/playlist?list=PLhfrWIlLOoKM3niunUBTLjOR4gMt_uR_a
    CCNA course: http://bit.ly/2PmTVPD

    ======================
    Free Network Software:
    ======================
    Solar-PuTTY: http://bit.ly/SolarPutty
    SolarWinds TFTP Server: http://bit.ly/2mbtD6j
    WAN Killer: http://bit.ly/wankiller
    Engineers Toolset: http://bit.ly/gns3toolset
    IP Address Scanner: http://bit.ly/swipscan
    Network Device Scanner: http://bit.ly/swnetscan
    Wifi Heat Map: http://bit.ly/wifiheat
    Wifi Analyzer: http://bit.ly/swwifianalyzer
    SolarWinds NPM: http://bit.ly/getnpm

    ========================
    Switch configuration:
    ========================

    c2960-CG#sh run
    Building configuration…

    Current configuration : 2984 bytes
    !
    version 15.0
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname c2960-CG
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    !
    ip dhcp pool vlan1
    network 10.1.1.0 255.255.255.0
    default-router 10.1.1.254
    dns-server 10.1.1.254
    !
    ip dhcp pool vlan2
    network 10.1.2.0 255.255.255.0
    default-router 10.1.2.254
    dns-server 10.1.2.254
    !
    !
    !
    !
    !
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    !
    !
    !
    !
    !
    !
    !
    !
    vlan internal allocation policy ascending
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/1
    !
    interface GigabitEthernet0/2
    switchport access vlan 2
    switchport mode access
    spanning-tree portfast
    !
    interface GigabitEthernet0/3
    !
    interface GigabitEthernet0/4
    !
    interface GigabitEthernet0/5
    !
    interface GigabitEthernet0/6
    !
    interface GigabitEthernet0/7
    !
    interface GigabitEthernet0/8
    !
    interface GigabitEthernet0/9
    !
    interface GigabitEthernet0/10
    !
    interface Vlan1
    ip address 10.1.1.254 255.255.255.0
    no ip route-cache
    !
    interface Vlan2
    ip address 10.1.2.254 255.255.255.0
    no ip route-cache
    !
    ip http server
    ip http authentication local
    ip http secure-server
    !
    !
    !
    !
    line con 0
    line vty 0 4
    password cisco
    login
    transport input all
    line vty 5 15
    login
    !
    end

    ========================

  2. Great to see you putting out Kali-based material, David. Looking forward to the others!

  3. Omg I’ve been waiting for this series on your channel for some time. Your content is amazing, I love your channel!

  4. Hi David…!!!! Nice video….how clear, crisp and deep are your videos…..love them the way you explain….god bless you 😀😀😀😀

  5. In this video David said, you do not have to watch my course go watch other youtubers if u want but i assure you watch his tutorials. It will change ur life. (PS:yeah indeed there are a lot of good youtubers, I respect and love them as well). I am a simple guy, how do love hacking and i can tell u after knowing networking I do big steps in cyber security.So my friend, if u want to be a good network pentester (i hope one day aswell)then start with David's tutorials. PS: most of them here in youtube but do not forget go to udemy for more.

  6. are we supposed to use default vlan in cisco switches, as I have learnt that using default vlan is insecure and need to move all un-used ports to another vlan.

    please advise. ta.

  7. Hi David, Can I attacking the physical network while I stay connect ?

  8. I didn't usually comment on Youtube….but your videos….loving them..!!!! <3 <3

  9. Hi David…

    Excellent Video, Keep it up.I am very crazy these type of videos. I am learning day by day. Your Teaching method and explainaion both are good.

    I would request you that please make network diagram using GNS3 / White board with physical topology for better understanding.

    Many Thanks

    Regards

    Usman From Pakistan

  10. Network Admin should shutdown unused ports and apply port security on active switch interface and disable DTP and VTP , change Default vlans and
    no cde enable on active switch ports other than uplink ports . CCNA teaches all these practices ! -> student at Cisco Networking Academy .

  11. Thank you sir loving your videos, want to have a conversation u in personal pls share ir social website handles if u dont mind

  12. Hi David, thanks for making the videos, knowing that you are also using GNS3 with Mac, want to see if you have any recommendation for "chicken of VNC" replacement? It seems will not work anymore on Catalina

  13. many learning channels on the internet, you are very good David. I love your effort for videos and good explaining.

  14. Informative video David. Also appreciate your desk / studio. It's eye-catching..

  15. Thanks David, to me what would be helpful now is to know how to shut down or prevent a hack on the switch.

Leave a Reply

Your email address will not be published. Required fields are marked *